Glitches problem

Report bugs and unexpected behavior here.
gialandra
Posts: 15
Joined: Wed Mar 27, 2013 7:47 am

Glitches problem

Post by gialandra » Mon Sep 30, 2013 10:43 am

Hi, with my Galaxy Nexus last 4.3 CyanogenMod I experience boring glitches that I can not resolve. I tried tweaking Hw/sw latency, keep away the CPU domanding process, but glitches remain. What can I do?

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Glitches problem

Post by dmitrykos » Mon Sep 30, 2013 11:16 am

Hi! Do you mean interruptions of audio (unstable) when you switch off the display of device?

gialandra
Posts: 15
Joined: Wed Mar 27, 2013 7:47 am

Re: Glitches problem

Post by gialandra » Mon Sep 30, 2013 12:58 pm

The playback is similar to play a scratched LP with random timing. They are present even with screen off

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Glitches problem

Post by dmitrykos » Mon Oct 14, 2013 7:43 am

Since next update you will find new option in Settings -> Audio Hardware. It will be named 'CPU Wake Lock'. By default it is turned off. Try it turning on and check if glitches go away. It would be great to know the results.

gialandra
Posts: 15
Joined: Wed Mar 27, 2013 7:47 am

Re: Glitches problem

Post by gialandra » Tue Oct 15, 2013 7:20 am

Ok, I will try it when it return from service. Can the glitches due to (Franco) kernel?

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Glitches problem

Post by dmitrykos » Wed Oct 16, 2013 11:51 am

Yes, it can be due to a kernel. Neutron is declaring as foreground process when playing and most probably your kernel is ignoring it and cutting the availability of CPU time.

1.75 is released and you will find CPU Wake Lock option in Audio Hardware. Would you please activate it and see if it helped.

linutux
Posts: 2
Joined: Sat Nov 09, 2013 11:25 pm

Re: Glitches problem

Post by linutux » Sun Nov 10, 2013 12:08 am

I'm having this problem on a Nexus 5 with Kit Kat. It only occurs with the OpenSL ES driver selected. It never happens with the AudioTrack(JNI) driver.

Setting "CPU Wake Lock" does not help. I've also tried numerous combinations of Hardware Latency and Software Latency with no change. Seems like its a process scheduling issue maybe?

I have an Asus Transformer Prime tablet running 4.1 that does not have this problem with either driver.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Glitches problem

Post by dmitrykos » Mon Nov 11, 2013 7:53 pm

Yes, it does depend on firmware configuration very much. It does not even matter how fast hardware is.

> AudioTrack

Open SL does not increase quality of audio it on some firmwares relaxes CPU usage (for example Galaxy S2) but if it is unstable then better use AudioTrack. Audio result is absolutely the same.

HokieMatt
Posts: 26
Joined: Tue Jan 15, 2013 5:52 pm

Re: Glitches problem

Post by HokieMatt » Wed Nov 13, 2013 2:08 am

I am also having this problem on a Cowon Z2. Running 1.75.4, track playback hiccups randomly. As metioned upthread it sounds like a scratched vinyl record. The application also randomly quits to the home screen during playback. I tried the normal release (non-NEON) and it wouldn't even start - crashed to desktop during the loading screen.

EDIT - I forgot to mention, I tried the CPU Wake Lock setting and it had no effect.

HokieMatt
Posts: 26
Joined: Tue Jan 15, 2013 5:52 pm

Re: Glitches problem

Post by HokieMatt » Wed Nov 13, 2013 9:08 pm

Dmitry - I have some more information that will hopefully help you to troubleshoot. I found that on my device, this is only happening with WMA format tracks at 160kbps. In addition, the tracks that are skipping also sound like they are being played at max volume, i.e. there is considerable distortion regardless of the actual volume. 128kbps or VBR WMA's sound fine and do not skip. OGG, MP3 and FLAC files also seem to be fine. I tried playing the files Neutron is having trouble with on Cowon's native music app and they sound fine.

Post Reply

Who is online

Users browsing this forum: No registered users and 22 guests