[UNCONFIRMED] Shuffle issue (again!)

Report bugs and unexpected behavior here.
Post Reply
rs219
Posts: 43
Joined: Tue Jan 03, 2012 12:58 pm

[UNCONFIRMED] Shuffle issue (again!)

Post by rs219 » Fri Dec 06, 2013 1:19 pm

The automatic "shuffle is turned on the next time you turn on the phone/player" has re-surfaced.

The scenario is: Pause a song (being played from an entire album) and then turn off your phone/player. When you turn on your phone/player, press play to resume where it left off (that part works fine), but then the automatic shuffle ruins the order of the album as it is getting turned on. Note that I never power down the phone/player as the song is being played (always pause and then shut down).

When I lasted reported this problem, several versions ago, the response was that there was something going on in the Android OS that could not be prevented (I don't remember the exact details). However, since then and up to the one of the last Neutron updates (not the most recent) the problem did not re-surface. Now it has.

Please do one of the following:

1. Fix the problem once and for all.
2. If #1 is not possible (which seems pretty unreasonable), then please add an Option in Settings that will BLINK the shuffle icon when the shuffle is turned on so that it is immediately and very noticeable!!!

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Shuffle issue (again!)

Post by dmitrykos » Fri Dec 13, 2013 9:29 pm

I tried to reproduce the issue using the described steps but could not. What I did:

- loop & shuffle off
- started playing track fro one of albums from Media Library screen -> Albums -> some album
- paused playback
- exited UI with Back button and restarted device
- started Neutron
- pressed play
- track started playing from the last playback position
- shuffle or any other unexpected behavior wasn't noticed

May be the issue you noticed is fixed already. Let's see how it will be after next update.

rs219
Posts: 43
Joined: Tue Jan 03, 2012 12:58 pm

Re: [UNCONFIRMED] Shuffle issue (again!)

Post by rs219 » Sat Dec 14, 2013 2:13 pm

Thanks for trying to reproduce. It is an intermittent problem, yet it will happen consistently over time. Something that could be a factor (although not logical) is that I only play FLAC files. Can you try it with FLAC? In your steps to reproduce, I don't see that you turned off the player. Step 1 should be to turn on your device and the last step should be to turn off your device. So, to get the problem setup you have to pause the FLAC song after playing song#X (paused at the beginning of song#Y), shut off the device, turn on the device, start Neutron which should be at the beginning of song#Y. If that does not reproduce the problem, you may have to repeat the steps several times and each time you do repeat the steps, select another album, play the first song, pause at the beginning of the next song, turn off the device, turn on the device, start Neutron. If you repeat this several times (perhaps try 10 times), I think you may be able to reproduce the problem.

If the next update does not address any fixes to something related to what is going on here, I have doubts the next update will have any affect. In the first thread I started on this, I recall you mentioning that Android was doing something with a service and that the only way to stop the behavior was to turn off that service.

rs219
Posts: 43
Joined: Tue Jan 03, 2012 12:58 pm

Re: [UNCONFIRMED] Shuffle issue (again!)

Post by rs219 » Mon Feb 17, 2014 7:35 pm

It would be nice if we could get a response to this issue. After the Feb 17 update, the problem persists!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests