Ignore from media library - bug

Support questions for Neutron Player only.
Post Reply
Vaze
Posts: 3
Joined: Fri Aug 02, 2013 8:58 am

Ignore from media library - bug

Post by Vaze » Sat Aug 23, 2014 4:57 pm

I noticed a typo in a title (not the name) of a song so I fixed it ["03 - Who's There_.mp3" ==> "03 - Who's There.mp3"]. The problem starts now. After doing a refresh of the sources and waiting for it to complete, The title of the song was still not fixed in Neutron. Then I got angry and after a few more refreshes and restarts I set it to ignore the song in the media library from the "Folders" section. It was still present in the playlist, but not in "Folders". This is still not the bug. Then I removed the song with my computer, refreshed, put it back, refreshed and the title was alright now. Checked the "Folders" section again and the above mentioned song was still missing from there. Still ignored. It is in the playlist and the SD card though. So now it shows one song less and there is no way to reverse it.
I understand the ignore function in the playlist, but the folders section? It's irreversible! Seriously? I bet this is a bug or there is a very well hidden solution for it.

How can I fix this? Without placing the song elsewhere/renaming it...

Edit:
I opened neutronmp.db with SQLite Database Browser and deleted plist_music_ignore_v2, where the path to the song was located, but it was still ignored even after a refresh. In settings I got Service option checked, so I closed Neutron and flushed RAM, started Neutron again, rescanned source manually by long-click -> SCAN, checked the song an it was there. Finally. After 2 hours of searching for a suitable program and the right line to remove, trial and error. To whoever made this the only way to fix it: "Good one! But not funny." :evil:
Anyway, problem solved but the bug still remains and needs to be fixed.

remedy69
Posts: 2
Joined: Thu Jan 04, 2018 4:57 am

Re: Ignore from media library - bug

Post by remedy69 » Thu Jan 04, 2018 5:52 am

Vaze wrote:I noticed a typo in a title (not the name) of a song so I fixed it ["03 - Who's There_.mp3" ==> "03 - Who's There.mp3"]. The problem starts now. After doing a refresh of the sources and waiting for it to complete, The title of the song was still not fixed in Neutron. Then I got angry and after a few more refreshes and restarts I set it to ignore the song in the media library from the "Folders" section. It was still present in the playlist, but not in "Folders". This is still not the bug. Then I removed the song with my computer, refreshed, put it back, refreshed and the title was alright now. Checked the "Folders" section again and the above mentioned song was still missing from there. Still ignored. It is in the playlist and the SD card though. So now it shows one song less and there is no way to reverse it.
I understand the ignore function in the playlist, but the folders section? It's irreversible! Seriously? I bet this is a bug or there is a very well hidden solution for it.

How can I fix this? Without placing the song elsewhere/renaming it...

Edit:
I opened neutronmp.db with SQLite Database Browser and deleted plist_music_ignore_v2, where the path to the song was located, but it was still ignored even after a refresh. In settings I got Service option checked, so I closed Neutron and flushed RAM, started Neutron again, rescanned source manually by long-click -> SCAN, checked the song an it was there. Finally. After 2 hours of searching for a suitable program and the right line to remove, trial and error. To whoever made this the only way to fix it: "Good one! But not funny." :evil:
Anyway, problem solved but the bug still remains and needs to be fixed.
Thanks for this... This was the only way I was able to restore a track that I had accidentally "ignored". Not sure what the official response is but this should not be as exhaustive a solution as it was...

MotleyG
Posts: 74
Joined: Thu Sep 23, 2021 6:19 pm

Re: Ignore from media library - bug

Post by MotleyG » Wed Jul 27, 2022 1:18 pm

Old thread I know, but this is directly related. I found several dating back to 2011 for the same issue, but this one seems to be the most accurately described issue.

I "Ignored" an album that I wanted to hide temporarily from the Albums list. Note this was not done using a source or folder view, but the actual album list.

Now I want to restore access to that album, but there is no way to find it to remove the ignore flag.

Steps I have tried so far;
1. Look for the album and files for the actual tracks in a separate file browser. Confirmed they are there. In fact from here I can open and play the songs in Neutron. But this does not add any of the tracks back to the media library browser. So this only adds to the frustration.
2. While playing one of the ignored tracks using the browser method, long press on the track info at the bottom of the now playing display. Details about the metadata and storage location appear, but there is not option there to restore the track to the library, or to remove the ignore radio button.
3. Added the folder for this album as a new source. Confirmed, yet the same files are not added to the media library.
4. Use the folder option in Neutron's browser - I can drill all the way into the AlbumArtist folder and see all other albums, other than the one that was ignored. So even in this menu the ignore function has blinded Neutron from seeing this album.

The steps to modify the .db file in the above first post seem like a pretty barbaric method to undo what appears to have been a simple task to temporarily hide this album. And the brute force method of deleting the entire database so that Neutron can start fresh is an even worse option.

Surely there is a better way to reverse the ignore request?

blaubär
Posts: 2713
Joined: Tue Apr 02, 2019 6:48 am

Re: Ignore from media library - bug

Post by blaubär » Wed Jul 27, 2022 2:10 pm

MotleyG wrote:
Wed Jul 27, 2022 1:18 pm
Surely there is a better way to reverse the ignore request?
Afaik a rescan of the source would clear all ignore flags.

MotleyG
Posts: 74
Joined: Thu Sep 23, 2021 6:19 pm

Re: Ignore from media library - bug

Post by MotleyG » Wed Jul 27, 2022 2:41 pm

blaubär wrote:
Wed Jul 27, 2022 2:10 pm
MotleyG wrote:
Wed Jul 27, 2022 1:18 pm
Surely there is a better way to reverse the ignore request?
Afaik a rescan of the source would clear all ignore flags.
Unfortunately this didn't help.
I refreshed, did a full rescan, removed then reassigned the source... none of these have restored access to the album. This was on an Android device. I tested another on a not-so-important album on IOS and had the same result.

I have sent the details of what has happened and what I have tried to restore it to support. I'll update if a working solution comes back.

blaubär
Posts: 2713
Joined: Tue Apr 02, 2019 6:48 am

Re: Ignore from media library - bug

Post by blaubär » Wed Jul 27, 2022 5:49 pm

Yes, I can reproduce that.
---
Furthermore I tried to reproduce this with an album where the songs are defined by a cue file. Immediately after ignoring the GUI stopped working. After killing and restarting the GUI worked again, the track wasn't ignored, contrary to my expectations.

MotleyG
Posts: 74
Joined: Thu Sep 23, 2021 6:19 pm

Re: Ignore from media library - bug

Post by MotleyG » Thu Aug 04, 2022 10:33 am

I reached out to support, and have found the solution for this. In the main library browser, long-press on Songs> then select the “-Ignore” setting. This will open a list of tracks currently on the ignore list. From here you can select any or even all tracks to be restored, then press the bottom check mark button. These tracks then become usable again within Neutron.

I did a refresh after this to make sure all lists updated.

blaubär
Posts: 2713
Joined: Tue Apr 02, 2019 6:48 am

Re: Ignore from media library - bug

Post by blaubär » Thu Aug 04, 2022 11:34 am

MotleyG wrote:
Thu Aug 04, 2022 10:33 am
In the main library browser, long-press on Songs> then select the “-Ignore” setting. This will open a list of tracks currently on the ignore list. From here you can select any or even all tracks to be restored, then press the bottom check mark button. These tracks then become usable again within Neutron.
Thanks a lot !

Screenshot 2022-08-04 133402.jpg
Screenshot 2022-08-04 133402.jpg (11.93 KiB) Viewed 539 times

MotleyG
Posts: 74
Joined: Thu Sep 23, 2021 6:19 pm

Re: Ignore from media library - bug

Post by MotleyG » Fri Aug 05, 2022 10:52 am

I guess the problem here is that you can set the ignore state in many different places. It can be at the Artist, Album, Composer levels, or even if you have drilled down through those library modes. So naturally that is where one might look to go back and restore them. But using the songs list is acceptable, as you can selectively add only the actual tracks to be restored.

Post Reply

Who is online

Users browsing this forum: No registered users and 13 guests