Spectrum Analyzer and other questions.

Report bugs and unexpected behavior here.
htom
Posts: 30
Joined: Wed Oct 26, 2011 7:45 pm

Spectrum Analyzer and other questions.

Post by htom » Wed Oct 26, 2011 8:01 pm

I've noticed that once the player screen is in landscape mode that tapping on the spectrum analyzer changes it to a fullscreen mode, but on my phone (Galaxy 2S) the frequency axis only extends to about 16200Hz. Should I be seeing it go to 22000Hz? I don't see anything that resizes the scales in any way.

Second question is, how do we know if we're running the neon version or not? And is that one only available for download through your webpage?

Third question: when playing back an album, how do I get back to the tracklist screen? If I go where I think I should I get to the screen for playlists/artists/albums/genres/songs but not the list for the specific album I was listening to.

Thanks again. The questions really only relate to minor issues, as the player works as well as I hoped.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Spectrum Analyzer and other questions.

Post by dmitrykos » Fri Oct 28, 2011 10:59 am

> 16200Hz. Should I be seeing it go to 22000Hz?

Yes it is up to around 16 kHz. Later I can expand this window to 22.5 kHz. E.g. you will be able to scroll window to the left and see its right part.

> running the neon version or not

Currently, this is unknown. You can only know it if you downloaded NEON version and installed it over. I will think to mark NEON version somehow.

> how do I get back to the tracklist screen

I am very sorry, but did not get the question. Could you please clarify it once again.

htom
Posts: 30
Joined: Wed Oct 26, 2011 7:45 pm

Re: Spectrum Analyzer and other questions.

Post by htom » Fri Oct 28, 2011 4:39 pm

dmitrykos wrote:> how do I get back to the tracklist screen

I am very sorry, but did not get the question. Could you please clarify it once again.
Sorry. Specifically, when I am playing back not a playlist, but a specific album, I note that scrolling back to the right only gets me back to the screen showing playlists/artists/albums/genres/songs/queue. I think I expected to get back to the screen displaying the specific album tracks, but in thinking about it now I'm not sure I ever saw this player doing it that way. If calling up the album's tracks is done a different way, please let me know.

Thanks again.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Spectrum Analyzer and other questions.

Post by dmitrykos » Fri Oct 28, 2011 6:05 pm

You shall be left in the screen with album tracks if you did not move from it with PREV button and did not enter to other albums/artists/genres. If you used just PREV button to get to top level and did not enter to anything else then pressing repeatedly on NEXT button shall return you back.

Anyway, I will think how to improve this and move straight to the currently playing entries! (May be pressing on path string '/Albums/XXX' ... will think...).

htom
Posts: 30
Joined: Wed Oct 26, 2011 7:45 pm

Re: Spectrum Analyzer and other questions.

Post by htom » Tue Nov 22, 2011 8:33 pm

Hi,

One more oddity is that on occasion, I'll play an album through to the end and the player will stop. When I go back to the album listing and choose the same album the tracklist is empty (blank). This does not happen all the time, though. Of course it is still possible to use the player interface and the 'back' button to revisit a track in the album.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Spectrum Analyzer and other questions.

Post by dmitrykos » Tue Nov 22, 2011 8:45 pm

Hi! :D

Thank you very much for the bug description. I managed to reproduce this bug. Although 1.41.1 is out, will make another patch release specifically for this case.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Spectrum Analyzer and other questions.

Post by dmitrykos » Tue Nov 22, 2011 9:32 pm

The fix is included in 1.41.2 release.

htom
Posts: 30
Joined: Wed Oct 26, 2011 7:45 pm

Re: Spectrum Analyzer and other questions.

Post by htom » Tue Dec 13, 2011 8:08 pm

Hi,

I don't know if these are application-specific issues or issues with the phone itself, but

1) occasionally the application will stay 'stuck' on the landscape screen, and the only way to get out of it is to kill the player through the task manager. I note the screen itself retains the play/pause/next track/previous track functionality.

2) upon starting up the player I can hear a small amount of noise (something close to a crackling sound) if my earphones are already plugged in. I can't hear it once the player is playing back; that is, the noise cannot be heard during silent passages in the music.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Spectrum Analyzer and other questions.

Post by dmitrykos » Wed Dec 14, 2011 10:58 am

Hi!

> 'stuck' on the landscape screen
Does it get stuck in Landscape mode when inside spectrum analyzer? Or simply when device is rotated?

> small amount of noise
I had some strange reports like noise in one of channels and etc and in most cases it was fault of hardware of device. To fix it users shutdown the device and take out battery. Could you please do the same and check again? Also if noise is still there, could you please switch off EQ (if it is ON) and check the noise presence (some OS may have bug in thread scheduler and when device is loaded at some degree could misbehave, I met such bug in Galaxy Ace when non-playing device with EQ on [EQ adds some +5-6% of consumption] starts consuming large % of CPU).

Could you please also mention:
- OS version
- Device model

htom
Posts: 30
Joined: Wed Oct 26, 2011 7:45 pm

Re: Spectrum Analyzer and other questions.

Post by htom » Wed Dec 14, 2011 8:00 pm

>Does it get stuck in Landscape mode when inside spectrum analyzer? Or simply when device is rotated?

It defaults to that mode on occasions when I place the phone on a tabletop (connected to external speakers, for example)

>I had some strange reports like noise in one of channels and etc and in most cases it was fault of hardware of device.
>To fix it users shutdown the device and take out battery. Could you please do the same and check again? Also if noise
>is still there, could you please switch off EQ (if it is ON) and check the noise presence (some OS may have bug in
>thread scheduler and when device is loaded at some degree could misbehave, I met such bug in Galaxy Ace when
>non-playing device with EQ on [EQ adds some +5-6% of consumption] starts consuming large % of CPU).

Swapping out the battery doesn't stop it from happening, but I also note that it seems to happen while the music DB is being either initialized or acquired by the player, which I see as the line of 'dashes' underneath the track time display turning red. The moment it turns white again the noise disappears. As to other parameters, EQ is usually off.

>Could you please also mention:
>- OS version
>- Device model

Samsung Galaxy IIS (GT-I9100M)
Android 2.3.3

Post Reply

Who is online

Users browsing this forum: No registered users and 22 guests