Troubles when playing radios from playlists

Report bugs and unexpected behavior here.
Post Reply
javaman
Posts: 8
Joined: Tue May 21, 2019 5:40 am

Troubles when playing radios from playlists

Post by javaman » Tue Nov 12, 2019 4:04 am

Hi.
I've collected some streaming radiostations and placed them into playlists.

First bug:
When playing a station from playlist, i push Pause, then after some time Play again, and Neutron plays a few seconds of rest of music from buffer and hangs. No playback, just center button (Play/Pause) jumps to pause and back to play, like it is no internet connection. This problem is not only related to pause function, but also to situation when i'm driving a car and enter to bad gsm signal zone - music stops and not resumes when connection gets back again. I can only choose other station and then return back to previous, then it plays until next break.

But when listening radio from "Streaming" source - it's working fine: when resuming playback - it plays current stream content, just skipping the rest of a buffer.

I've prefer to use playlists (divided by genre), because i have a lot of stations collected, and it's not convenient to keep them all in "Streaming" source list.

Second bug is with "Streaming" source list. When i play a station, then minimize Neutron to background, then change a station via Android Navigation bar buttons (PREV / NEXT) or via media buttons, the station changes correctly. BUT! When i start Neutron UI main activity - it jumps back to the original station, like it remembers it when it was minimized and recalls it back when maximized.

Third thing is a wish about playlists - is it possible to switch to prev / next station when playing from playlist, like in "streaming" source? Now it is not working.

blaubär
Posts: 1314
Joined: Tue Apr 02, 2019 6:48 am

Re: Troubles when playing radios from playlists

Post by blaubär » Sun Nov 17, 2019 3:19 pm

javaman wrote:
Tue Nov 12, 2019 4:04 am
First bug:
When playing a station from playlist, i push Pause, then after some time Play again, and Neutron plays a few seconds of rest of music from buffer and hangs. No playback, just center button (Play/Pause) jumps to pause and back to play, like it is no internet connection. This problem is not only related to pause function, but also to situation when i'm driving a car and enter to bad gsm signal zone - music stops and not resumes when connection gets back again. I can only choose other station and then return back to previous, then it plays until next break.
I could reproduce that: created a playlist containing a radio stream, let it play via playlist, stopped it, waited for some minutes, restarted it - it showed a new song, played for some seconds, then stopped, play button not responsive. Back to the playlist and restarting from there worked. The same directly from the streaming worked.

blaubär
Posts: 1314
Joined: Tue Apr 02, 2019 6:48 am

Re: Troubles when playing radios from playlists

Post by blaubär » Sun Nov 17, 2019 4:24 pm

I don't know whether this is related and if it's a bug or a feature, but you can add a stream from icecast and shoutcast to the streaming category

add-to-streaming.PNG
add-to-streaming.PNG (24.75 KiB) Viewed 943 times
but you cannot do so from the playlist

stream-in-playlist.PNG
stream-in-playlist.PNG (19.29 KiB) Viewed 943 times
Perhaps the stream isn't fully recognized as a stream once it is in the playlist ?

blaubär
Posts: 1314
Joined: Tue Apr 02, 2019 6:48 am

Re: Troubles when playing radios from playlists

Post by blaubär » Wed Mar 04, 2020 6:57 am

javaman wrote:
Tue Nov 12, 2019 4:04 am
First bug:
When playing a station from playlist, i push Pause, then after some time Play again, and Neutron plays a few seconds of rest of music from buffer and hangs. No playback, just center button (Play/Pause) jumps to pause and back to play, like it is no internet connection. This problem is not only related to pause function, but also to situation when i'm driving a car and enter to bad gsm signal zone - music stops and not resumes when connection gets back again. I can only choose other station and then return back to previous, then it plays until next break.
Seems to be solved in the new version 2.13.0, I couldn't reproduce the error - could you please check ? When I stop the playlist/stream, wait some time, restart, then it plays for some seconds the buffered and stopped stream, then resumes the stream.
dmitrykos wrote:
Fri Feb 14, 2014 7:22 pm
[...]
* Improved:
[...]
- network stream reloading.
[...]
Fixed:
[...]
- tracks from the playlist could not be matched to tracks of the media library;
[...]

blaubär
Posts: 1314
Joined: Tue Apr 02, 2019 6:48 am

Re: Troubles when playing radios from playlists

Post by blaubär » Wed Mar 04, 2020 7:38 am

javaman wrote:
Tue Nov 12, 2019 4:04 am
Third thing is a wish about playlists - is it possible to switch to prev / next station when playing from playlist, like in "streaming" source? Now it is not working.
That works for me if I play a playlist/stream and then tap the group switch buttons. It then switches to the previous/next stream. ( But not the precious/next playlist - is that what you want ? It would seem that starting a stream via playlist is just a shortcut to the streaming sources )

javaman
Posts: 8
Joined: Tue May 21, 2019 5:40 am

Re: Troubles when playing radios from playlists

Post by javaman » Mon Mar 09, 2020 3:18 am

blaubär wrote:
Wed Mar 04, 2020 7:38 am
That works for me if I play a playlist/stream and then tap the group switch buttons. It then switches to the previous/next stream. ( But not the precious/next playlist - is that what you want ? It would seem that starting a stream via playlist is just a shortcut to the streaming sources )
Yes, you're right, playlists seems to be used just as shortcuts to "Streaming". When playing a station which is added only to playlist, not to streaming list, group buttons are not shown at all. Otherwise, group buttons switch to prev/next station in "streaming" list in alphabetical order. And taping the bottom area with station title in "current playing" screen - leads to display current station in "streaming" list, not the initial playlist.

javaman
Posts: 8
Joined: Tue May 21, 2019 5:40 am

Re: Troubles when playing radios from playlists

Post by javaman » Mon Mar 09, 2020 3:21 am

blaubär wrote:
Wed Mar 04, 2020 6:57 am
javaman wrote:
Tue Nov 12, 2019 4:04 am
First bug:
When playing a station from playlist, i push Pause, then after some time Play again, and Neutron plays a few seconds of rest of music from buffer and hangs. No playback, just center button (Play/Pause) jumps to pause and back to play, like it is no internet connection. This problem is not only related to pause function, but also to situation when i'm driving a car and enter to bad gsm signal zone - music stops and not resumes when connection gets back again. I can only choose other station and then return back to previous, then it plays until next break.
Seems to be solved in the new version 2.13.0, I couldn't reproduce the error - could you please check ? When I stop the playlist/stream, wait some time, restart, then it plays for some seconds the buffered and stopped stream, then resumes the stream.
Checked, pause works fine, looks like this bug is fixed.

Post Reply

Who is online

Users browsing this forum: No registered users and 25 guests