album art pain {not always shown}

Report bugs and unexpected behavior here.
Post Reply
CJMCDM
Posts: 31
Joined: Sun Feb 12, 2012 12:54 am

album art pain {not always shown}

Post by CJMCDM » Sun May 27, 2012 4:40 am

Im one of those guys obsessed with having the album art tagged to perfection.
But Neutron has fallen short in meeting my expectations in that area, I tried refreshing, but many times it wont see the album art, its not illicit music, its from Itunes.
Okay, one song is pirated, but russian music is hard to find here; anyway no matter how hard I've tried, nothing has worked and I currently have like 3 albums without their album art assigned,
but some have only ONE song, it will show the correct album art when playing the song but not in the album menu.
please help!

Nostrovia
Posts: 36
Joined: Fri Jan 13, 2012 2:50 am

Re: album art pain

Post by Nostrovia » Sun May 27, 2012 9:30 am

CJMCDM wrote:Im one of those guys obsessed with having the album art tagged to perfection.
Hi CJMCDM, well meet another who is also somewhat obsessed with having tags, including album art pretty well darn near perfect!

As such I'm yet to encounter any such issues. I'd say you need Dimitry's help here, but have you tried retagging on your computer the 3 albums in their entirety?

If you are referring to full albums it's likely Itunes has not properly tagged each and every file of those albums. Itunes is notorious for having these kind of errors!

Do you see that album art is present with each file? :?

Cheers.

Liveinthemoment
Posts: 209
Joined: Fri Feb 24, 2012 2:40 am

Re: album art pain

Post by Liveinthemoment » Sun May 27, 2012 9:38 am

I had this exact issue with 1 out of 500 CDs that I have.

I must have spent 4 hours in total time trying to fix it.

I think 1 tag at least of the 12 songs in the album's directory is corrupted but the corruption is not detectable using error checking software.

Re-tagging all the 12 files with a different picture for the album seemed to be the solution initially but the error remains so a complete delete and rebuild leaves you back with the problem eventually and it will be unsolvable even though I tried to delete the album from the tags and have only a JPEG in the directory.

Anyone get further on that let me know.

CJMCDM
Posts: 31
Joined: Sun Feb 12, 2012 12:54 am

How I could have not noticed before!

Post by CJMCDM » Mon May 28, 2012 2:29 am

You're right!!!
All albums in the "blacklist" of album art are from Itnes, Actually I prefer amazon MP3 store (as music is great quality and tagged to perfection) I just purchased from there be ause I had a gift card.. So that kinda solves part of the problem as I now see the cause, but I still need a solution

Liveinthemoment
Posts: 209
Joined: Fri Feb 24, 2012 2:40 am

Re: album art pain

Post by Liveinthemoment » Mon May 28, 2012 8:20 am

Best solution is to use this software on your PC to fix those tags.

http://www.mp3tag.de/en/

So I recommend
1) deleting the directory(ies) (if albums are in their own directories or files as the case may be) from your Android device
2) rebuilding the database in Neutron
3) copying over the files after you have fixed them manually with mp3tag
4) rebuild the database again in Neutron

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: album art pain {not always shown}

Post by dmitrykos » Tue May 29, 2012 8:26 am

Hi CJMCDM! :)

It would be great to have your response regarding 're-scanning' of your music database and whether it helped you to get album art into Neutron music database (ref: http://neutronmp.com/forum/viewtopic.php?f=3&t=403).

Also, if you have some music files with embedded album art which is not shown by Neutron then it could be the problem in tag reading code which can be fixed if you e-mail to me such music files to neutronmp@gmail.com.

CJMCDM
Posts: 31
Joined: Sun Feb 12, 2012 12:54 am

Re: album art pain {not always shown}

Post by CJMCDM » Fri Jun 01, 2012 3:17 am

I have reescaned (I posted this new thread because it worked, but not for all, its kinda hard to find itcthough)
I still have two albums without their album art, I have checked in the album folder and there was no album art file, however all players have it (I have four,plus neutron) I havent downloaded it so Im not sure why they all have high quality album art.
Those are the only two not complete albums, and the only ones with only a song or two (the rest all are complete albums)

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: album art pain {not always shown}

Post by dmitrykos » Fri Jun 01, 2012 12:10 pm

> I havent downloaded it so Im not sure why they all have high quality album art

It can be such possibility: some music files of those albums may have album art embedded into their tags (there is no limitation on size of such data and quality may be high) and some not. Neutron, when seeing no image file in album folder, loads very first song of the album and checks whether it has embedded image.

So, I had some albums which had embedded art only in some music files and first song was without it and thus Neutron won't show art until I embed image into first song of that album.

Other players, or media scanner of Android OS may try scanning song by song of the album until album art image is found. That is why you see it in other players. Such long scanning procedure is very costly and may increase scanning times and CPU load.

Just try installing Mp3Tag application on PC and check music files of those 2 albums. Most likely you will see the picture I described above. If all are tagged though, please notify.

CJMCDM
Posts: 31
Joined: Sun Feb 12, 2012 12:54 am

Re: album art pain {not always shown}

Post by CJMCDM » Sun Jun 03, 2012 3:00 am

Ok, that will help, but it would be good if you add a "deep scan" option, so people can check all the tags of the albums but only when the users wish it.
that should help to solve other people's problems as well.
;)
I know it may be a hassle, but I know you are a dedicated developer so only good things could happen
:D

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests